Fossil

Check-in [f392fac705]
Login

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview
Comment:Added a hyperlink from the "upgrade to Fossil 2.1 or later" recommendation at the top of the hash policy document to the "Installing" section of the Quick Start document.
Downloads: Tarball | ZIP archive | SQL archive
Timelines: family | ancestors | descendants | both | trunk
Files: files | file ages | folders
SHA3-256: f392fac705e3ec87166e1c10a3b53a9f3c77558557b351914c3af7314a3a7eea
User & Date: wyoung 2019-01-10 17:29:39
Context
2019-01-10
18:25
Fix the remote_repo_info() function to avoid resource leaks and to suppress unhelpful error and warning messages. check-in: 1e3cfc1e9e user: drh tags: trunk
17:29
Added a hyperlink from the "upgrade to Fossil 2.1 or later" recommendation at the top of the hash policy document to the "Installing" section of the Quick Start document. check-in: f392fac705 user: wyoung tags: trunk
06:03
Fixed an errant use of a Markdown hyperlink in a Fossil wiki document. check-in: 15cbb09da3 user: wyoung tags: trunk
Changes
Hide Diffs Unified Diffs Ignore Whitespace Patch

Changes to www/hashpolicy.wiki.

2
3
4
5
6
7
8
9

10
11
12
13
14
15
16
17
18
19
20

<h2>Executive Summary</h2>

<b>Or: How To Avoid Reading This Article</b>

There was much angst over the [http://www.shattered.io|SHAttered attack]
against SHA1 when it was announced in early 2017.  If you are concerned
about this and its implications for Fossil, simply upgrade to Fossil 2.1

or later, and the problem will go away.  Everything will continue to work
as before.  All of your legacy repositories will continue to work, and
all of your old check-ins will still have the same name.  Your workflow
will be unchanged.

But if you are curious and want a deeper understanding of what is
going on, read on...


<h2>Introduction</h2>








|
>
|
|
|
|







2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21

<h2>Executive Summary</h2>

<b>Or: How To Avoid Reading This Article</b>

There was much angst over the [http://www.shattered.io|SHAttered attack]
against SHA1 when it was announced in early 2017.  If you are concerned
about this and its implications for Fossil, simply
[./quickstart.wiki#install|upgrade to Fossil 2.1 or later], and the
problem will go away.  Everything will continue to work as before.  All
of your legacy repositories will continue to work, and all of your old
check-ins will still have the same name.  Your workflow will be
unchanged.

But if you are curious and want a deeper understanding of what is
going on, read on...


<h2>Introduction</h2>

Changes to www/quickstart.wiki.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
<title>Fossil Quick Start Guide</title>
<h1 align="center">Fossil Quick Start</h1>

<p>This is a guide to get you started using fossil quickly
and painlessly.</p>

<h2>Installing</h2>

    <p>Fossil is a single self-contained C program.  You need to
    either download a
    <a href="https://www.fossil-scm.org/fossil/uv/download.html">precompiled
    binary</a>
    or <a href="build.wiki">compile it yourself</a> from sources.
    Install fossil by putting the fossil binary






|







1
2
3
4
5
6
7
8
9
10
11
12
13
14
<title>Fossil Quick Start Guide</title>
<h1 align="center">Fossil Quick Start</h1>

<p>This is a guide to get you started using fossil quickly
and painlessly.</p>

<h2 id="install">Installing</h2>

    <p>Fossil is a single self-contained C program.  You need to
    either download a
    <a href="https://www.fossil-scm.org/fossil/uv/download.html">precompiled
    binary</a>
    or <a href="build.wiki">compile it yourself</a> from sources.
    Install fossil by putting the fossil binary